Subversion Repositories Scribus

Rev

Rev 23489 | Rev 23852 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
23792 jghali 1
language: cpp
20294 craig 2
 
23792 jghali 3
os: linux
4
 
5
dist: focal
6
 
7
compiler:
8
  - clang
9
  - gcc
10
 
11
env:
12
  - NPROC=2
20294 craig 13
 
14
before_install:
23792 jghali 15
  - sudo apt-add-repository ppa:beineri/opt-qt-5.14.2-focal -y
16
  - sudo apt-get update -qq
17
 
22809 jghali 18
install:
23792 jghali 19
  - sudo apt-get install --force-yes cmake libboost-python-dev libcairo2-dev libcups2-dev libharfbuzz-dev libharfbuzz-icu0 libhunspell-dev libhyphen-dev liblcms2-dev libpng-dev libpodofo-dev libpoppler-dev libpoppler-cpp-dev libtiff-dev libxml2-dev qt514base qt514declarative qt514tools python3-all-dev python3-tk zlib1g-dev libgraphicsmagick++1-dev libopenscenegraph-dev libcdr-dev libmspub-dev libwpg-dev libvisio-dev coreutils binutils poppler-data libpoppler-private-dev libfreehand-dev libpagemaker-dev libqxp-dev libzmf-dev
20
 
20294 craig 21
script:
23792 jghali 22
  - source /opt/qt514/bin/qt514-env.sh
23
  - cmake . -DCMAKE_INSTALL_PREFIX=/usr -DWANT_HUNSPELL=1 -DWITH_PODOFO=1 -DWANT_GRAPHICSMAGICK=1 -DWANT_DEBUG=0 -DWANT_SVNVERSION=0 -DWANT_GUI_LANG=en_US
24
  - make -j"$NPROC"
25
  - sudo make install
26
  - sudo bash -ex ./AppImage-package/bundle.sh
20294 craig 27
 
23792 jghali 28
jobs:
29
  include:
30
    os: osx
31
    before_install:
32
      - brew update
33
    install:
34
      - brew outdated cmake || brew upgrade cmake
35
      - brew outdated zlib || brew upgrade zlib
36
      - brew outdated icu4c || brew upgrade icu4c
37
      - brew outdated xz || brew upgrade xz
38
      - brew outdated cairo || brew upgrade cairo
39
      - brew outdated qt5 || brew upgrade qt5
40
      - brew outdated little-cms2 || brew upgrade little-cms2
41
      - brew outdated poppler || brew upgrade poppler
42
      - brew outdated python || brew unlink python@2 && brew upgrade python
43
      - brew outdated jpeg || brew upgrade jpeg
44
      - brew outdated libpng || brew upgrade libpng
45
      - brew outdated libtiff || brew upgrade libtiff
46
      - brew outdated fontconfig || brew upgrade fontconfig
47
      - brew outdated pkg-config || brew upgrade pkg-config
48
      - brew outdated boost || brew upgrade boost
49
      - brew outdated freetype || brew upgrade freetype
50
      - brew outdated openssl || brew upgrade openssl
51
      - brew install hunspell podofo ghostscript graphicsmagick harfbuzz librevenge libwpg libvisio libmspub libcdr libpagemaker libfreehand # open-scene-graph
21563 jghali 52
 
23792 jghali 53
    before_script:
54
      - export PKG_CONFIG_PATH="$(pkg-config --variable pc_path pkg-config):/usr/local/opt/openssl/lib/pkgconfig:/usr/local/opt/qt/lib/pkgconfig:/usr/local/opt/icu4c/lib/pkgconfig"
55
      - export LDFLAGS="-L/usr/local/opt/zlib/lib -L/usr/local/opt/gettext/lib -L/usr/local/opt/libffi/lib -L/usr/local/opt/qt/lib -L/usr/local/opt/sqlite/lib -L/usr/local/opt/openssl/lib -L/usr/local/opt/icu4c/lib -L/usr/local/opt/hunspell/lib"
56
      - export CXXFLAGS="-I/usr/local/opt/zlib/include -I/usr/local/opt/gettext/include -I/usr/local/opt/qt5/include -I/usr/local/opt/sqlite/include -I/usr/local/opt/openssl/include -I/usr/local/opt/icu4c/include -I/usr/local/opt/hunspell/include"
57
 
58
    script:
59
      - cmake . -DCMAKE_INSTALL_PREFIX=~/.local -DWANT_HUNSPELL=1 -DWITH_PODOFO=1 -DWANT_GRAPHICSMAGICK=1 -DWANT_DEBUG=0 -DWANT_SVNVERSION=0 -DWANT_GUI_LANG=en_US -DWANT_NOOSG=1 -DBUILD_OSX_BUNDLE=1 -DCMAKE_OSX_ARCHITECTURES=x86_64 -DQT_PREFIX=/usr/local/opt/qt
60
      - make -j"$NPROC"
61
      - make install
62
 
63
 
20505 craig 64
notifications:
20844 jghali 65
  irc:
66
    channels:
23792 jghali 67
#    -  "chat.freenode.net#scribus"
68
#    -  "chat.freenode.net#scribus-dev"
20844 jghali 69
    template:
70
    - "%{repository}/%{branch} (%{author}): %{build_url}: %{message}"
71
    on_success: always
72
    on_failure: always