Subversion Repositories Scribus

Rev

Rev 1602 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
1433 mrdocs 1
This is Scribus Version 1.2.2
1064 cbradney 2
 
3
The Scribus 1.2.x versions feature a complete rewrite of the rendering engine.
4
All rendering is done via libart and freetype2.
388 Franz 5
This requires that libart_lgpl and freetype2 are installed.
3 paul 6
 
1433 mrdocs 7
Version 1.2.2 now includes the Short Words plug-in, which was previously
8
installed as a separate plug-in. To prevent upgrade problems, you might want to
9
uninstall if it was installed via a package or RPM. This was also shiped as the
10
scribus-vlna package in both source and rpm format.
11
 
1602 mrdocs 12
Scribus 1.2.2 also has a new OpenOffice.org Writer and Draw importer. This
1064 cbradney 13
requires libxml2, preferably version 2.6.x+. The OpenOffice.org Writer importer
14
will import styles from the OpenOffice.org doc and will create similar styles
15
within your Scribus document.
16
 
1602 mrdocs 17
Version 1.2.1 supported Open Office 1.1.x and Star Office 6/7 file formats.
18
Version 1.2.2 supports Open Office 2.x/Star Office 8.x (OASIS) as well.
1064 cbradney 19
 
1602 mrdocs 20
 
238 Franz 21
Additionally Scribus uses now a different way to find fonts, sadly this gives
1064 cbradney 22
some changes in the font names Scribus uses. To convert old documents follow
23
the procedure below:
3 paul 24
 
238 Franz 25
1) Create a document with the old Version of Scribus containing all your Fonts.
68 Franz 26
2) Open the new Scribus and go to the Font Substitution List.
1064 cbradney 27
3) Clear out all current substitutions.
28
4) Open the Document created in 1) and substitute all the fonts with the
29
   correct new fonts.
68 Franz 30
 
1064 cbradney 31
When you now open old documents Scribus will convert all Font Names
238 Franz 32
automatically.
33
 
3 paul 34
For Changes please see the ChangeLog.
35
 
1064 cbradney 36
To use Scribus in your native language be sure that the environment variable
37
LC_ALL, LC_MESSAGES, LANG, Qt locale, OR the command line option
38
of -l/--lang <lang> is set correctly.
3 paul 39
 
1064 cbradney 40
The new EPS/PS import feature in 1.2.x uses advanced features of Ghostscript.
41
We recommend ALL users update to the newest version of Ghostscript available
42
for your distro. There are detailed hints on docs.scribus.net for installing
43
GS 8.x in parallel to the GS installed by your distro.
302 Franz 44
 
1064 cbradney 45
Activating Color Management *requires* installation of CMYK and RGB ICC
46
profiles. Please see the included help files and http://docs.scribus.net for
47
details.
3 paul 48
 
238 Franz 49
Other notes/known issues at the time of release:
50
 
51
There is a bug in font outline handling for some fonts in the freetype
52
libraries. It's being worked on upstream. Don't file a bug report. Instead
388 Franz 53
change the font used if you need the outlines. This is not a Scribus bug.
54
Some testing has shown that this bug is not present in freetype 2.1.9, but
55
we counsel caution trying to upgrade freetype2. Upgrading freetype2 on some
56
distros can be quite difficult.
238 Franz 57
 
388 Franz 58
 
302 Franz 59
For Debian Users:
238 Franz 60
 
61
If Scribus does not start while complaining about the absence of
62
PostScript fonts please install either xfonts-scalable or gsfonts-x11.
63
They are in the "Recommends" and will be installed by all sensible apt
64
front-ends.
65
 
1064 cbradney 66
For SuSE 9.x Users:
238 Franz 67
 
1064 cbradney 68
- The littlecms libs 1.10, which shipped with 9.0 does not offer complete
69
  support for all the the latest CMS features in Scribus 1.2. There are updated
70
  SuSE 9.x RPM's available on the Scribus.net site. We also recommend using the
71
  latest version of lcms.
238 Franz 72
 
1064 cbradney 73
- If you are using Qt 3.3.x, please ensure you are using the latest Qt 3.3.2-2+
74
  rpms. The -2+ versions have an important fix for drag and drop in Scribus.
238 Franz 75
 
1630 mrdocs 76
- To enable direct CUPS support which we recommend, make sure both cups-devel and
77
  openssl-devel are installed. Suse enables ssl support in CUPS.
238 Franz 78
 
1064 cbradney 79
For Fedora/RH using Qt 3.3.2-6+ has the same fixes.
80
 
81
Many other hints and info are on the www.scribus.net and docs.scribus.net
82
sites. Full compile, install and FAQ's are available there.
83
 
84
There is a lively on-line community, both on IRC @ #scribus on irc.freenode.net
85
and the mailing list. Mailing list info can be found at:
86
 http://nashi.altmuehlnet.de/mailman/listinfo/scribus
87
 
302 Franz 88
For the Scribus Team,
238 Franz 89
 
3 paul 90
Franz Schmid
1064 cbradney 91
Peter Linnell
1630 mrdocs 92
in March 2005