Subversion Repositories Scribus

Rev

Rev 302 | Rev 437 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
388 Franz 1
This is Scribus Version 1.2
2
The Scribus 1.2 version features a complete rewrite of the rendering Engine.
3
All rendering is now done via libart and freetype2.
4
This requires that libart_lgpl and freetype2 are installed.
3 paul 5
 
238 Franz 6
Additionally Scribus uses now a different way to find fonts, sadly this gives
7
some changes in the font names Scribus uses. To convert old documents follow the
68 Franz 8
procedure below:
3 paul 9
 
238 Franz 10
1) Create a document with the old Version of Scribus containing all your Fonts.
68 Franz 11
2) Open the new Scribus and go to the Font Substitution List.
12
3) Clear out all current Substitutions.
238 Franz 13
4) Open the Document created in 1) and substitute all the fonts with the correct new Fonts.
68 Franz 14
 
238 Franz 15
When you open now old Documents Scribus will convert all Font Names
16
automatically.
17
 
3 paul 18
For Changes please see the ChangeLog.
19
 
238 Franz 20
To use Scribus in your native language be sure that the environment
21
variable LANG is set correctly.
3 paul 22
 
388 Franz 23
The new EPS/PS import feature in 1.2 uses advanced features of Ghostscript. We recommend
302 Franz 24
ALL users update to the newest version of Ghostscript avialable for your distro.
25
 
3 paul 26
Special note for SuSE 8.1 users, you need the devel packages, at least
27
xdevel.rpm, qtdevel.rpm and tiffdevel.rpm. In the Standard-Install they
28
were not installed.
29
 
238 Franz 30
Other notes/known issues at the time of release:
31
 
32
There is a bug in font outline handling for some fonts in the freetype
33
libraries. It's being worked on upstream. Don't file a bug report. Instead
388 Franz 34
change the font used if you need the outlines. This is not a Scribus bug.
35
Some testing has shown that this bug is not present in freetype 2.1.9, but
36
we counsel caution trying to upgrade freetype2. Upgrading freetype2 on some
37
distros can be quite difficult.
238 Franz 38
 
388 Franz 39
 
302 Franz 40
For Debian Users:
238 Franz 41
 
42
If Scribus does not start while complaining about the absence of
43
PostScript fonts please install either xfonts-scalable or gsfonts-x11.
44
They are in the "Recommends" and will be installed by all sensible apt
45
front-ends.
46
 
302 Franz 47
For SuSE 9.0/9.1 Users.
238 Franz 48
 
49
The littlecms libs 1.10, which shipped with 9.0 does not offer complete support
388 Franz 50
for all the the latest CMS features in Scribus 1.2. There are updated
51
SuSE 9.x RPM's available on the scribus.net site. We also recommend using the
52
latest version of lcms.
238 Franz 53
 
302 Franz 54
If you are using Qt 3.3.x, please ensure you are using the latest Qt 3.3.2-2+ rpms.
388 Franz 55
The -2+ versions have an important fix for drag and drop in Scribus.
238 Franz 56
 
302 Franz 57
Many other hints and info are on the www.scribus.net site. Full compile, install and FAQ's
238 Franz 58
are available there.
59
 
302 Franz 60
For the Scribus Team,
238 Franz 61
 
3 paul 62
Franz Schmid
388 Franz 63
in August 2004