Subversion Repositories Scribus

Compare Revisions

Regard whitespace Rev 25103 → Rev 25102

/branches/Version15x/Scribus/AppImage-package/bundle.sh
9,6 → 9,22
SCRIBUS_VERSION=nightly
 
########################################################################
# Build Platform Theme for Gtk+
# https://askubuntu.com/a/910143
# https://askubuntu.com/a/748186
# Deploy with linuxdeployqt using
# -extra-plugins=platformthemes/libqgtk2.so,styles/libqgtk2style.so
# At runtime, export QT_QPA_PLATFORMTHEME=gtk2 (Xfce does this itself)
########################################################################
 
git clone http://code.qt.io/qt/qtstyleplugins.git
cd qtstyleplugins
qmake
make -j$(nproc)
make install
cd -
 
########################################################################
# Build Scribus and install to appdir/
########################################################################
 
108,4 → 124,5
ARCH=x86_64 VERSION=$SCRIBUS_VERSION ./linuxdeployqt-continuous-x86_64.AppImage --appimage-extract-and-run appdir/usr/share/applications/scribus.desktop \
-appimage -unsupported-bundle-everything \
-executable=appdir/usr/bin/python3.6 \
-executable=appdir/usr/lib/python3.6/lib-dynload/_tkinter.cpython-36m-x86_64-linux-gnu.so
-executable=appdir/usr/lib/python3.6/lib-dynload/_tkinter.cpython-36m-x86_64-linux-gnu.so \
-extra-plugins=platformthemes/libqgtk2.so,styles/libqgtk2style.so
/branches/Version15x/Scribus/AppImage-package/AppRun
53,6 → 53,15
export TK_LIBRARY="${HERE}"/usr/share/tcltk/tk8.6:$TK_LIBRARY:$TCL_LIBRARY
 
############################################################################################
# Make it look more native on Gtk+ based systems
############################################################################################
 
case "${XDG_CURRENT_DESKTOP}" in
*GNOME*|*gnome*)
export QT_QPA_PLATFORMTHEME=gtk2
esac
 
############################################################################################
# Run experimental bundle that bundles everything if a private ld-linux-x86-64.so.2 is there
# This allows the bundle to run even on older systems than the one it was built on
############################################################################################