Subversion Repositories Scribus

Rev

Go to most recent revision | Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
18449 3177d 09h craig /trunk/Scribus/CMakeLists.txt Tidy up indenting in CMake files  
18447 3177d 09h craig /trunk/Scribus/CMakeLists.txt Remove USE_QT5 and all the Qt4 only code. Remove some QT version >4 code. Remove some cmake 2.6 cmake code, Set minimum cmake to 2.8.9 and qt min version to 5.0.0  
18404 3210d 08h craig /trunk/Scribus/CMakeLists.txt Move translation files out of po dir and remove it  
18403 3210d 08h craig /trunk/Scribus/CMakeLists.txt Ensure we have the Qt linguist tools, from opensuse  
18194 3354d 08h fschmid /trunk/Scribus/CMakeLists.txt Port to Qt5:
To enable building against Qt5 use the new commandline options:
-DUSE_QT5=1
-DQT_PREFIX="path _to_your_Qt5_installation"
when calling cmake
Only thing that does't work is the upgradechecker class as it depends on deprecated Qt4 classes, and needs a complete rewrite.
Default for building is still Qt4, so a normal cmake call without the options above still results in a build against
Qt4.
 
18186 3359d 08h craig /trunk/Scribus/CMakeLists.txt Push some of the Haiku stuff to 1.5.0svn even though we only support cairo in 1.5.x and cairo doesnt work on Haiku yet  
18099 3406d 07h craig /trunk/Scribus/CMakeLists.txt Comment out the aspell selection code  
17970 3436d 07h craig /trunk/Scribus/CMakeLists.txt Fix some CMake indentation, really make sure private cairo is not used if not selected  
17954 3443d 09h jghali /trunk/Scribus/CMakeLists.txt fix python 2.x detection when 2.x and 3.x are installed side-by-side + lcms2 includes being incorrectly picked up in some situations  
17625 3613d 09h jghali /trunk/Scribus/CMakeLists.txt fix potential conflict between some python and poppler headers on non case sensitive filesystems by using poppler and python includes only when strictly necessary  
17563 3623d 10h craig /trunk/Scribus/CMakeLists.txt Remove WANT_PRIVATE_CAIRO option from CMake options - it now sets WANT_SYSTEM_CAIRO, as private cairo is broken, broken, b0rken  
17537 3635d 12h jghali /trunk/Scribus/CMakeLists.txt msvc project update : some modifications to ease transition to msvc 2010/msvc 2012  
17501 3659d 09h craig /trunk/Scribus/CMakeLists.txt Port hunspell to trunk. Change hyphenation language storage to us the abbreviated version of the language. Rename en.xml from loremipsum to en_GB and hyph_en.dic hyph dict to hyph_en_GB.dic  
17500 3662d 08h craig /trunk/Scribus/CMakeLists.txt Per Gentoo's app-office/scribus/scribus-1.4.9999.ebuild, add in WANT_NOTEMPLATES for those that don't want to install templates, WANT_NOEXAMPLES to not install script samples (CMake options), only install README.MacOSX for OSX installs  
17204 3775d 05h jghali /trunk/Scribus/CMakeLists.txt Bump minimal qt version for building trunk to 4.7.0. Trunk does not build anymore with 4.6 anyway.  
16927 3858d 09h craig /trunk/Scribus/CMakeLists.txt #10328: Only set QT_MAC_USE_COCOA IF(APPLE)  
16856 3888d 08h craig /trunk/Scribus/CMakeLists.txt Commit GSoC 2011 Tables work so it doesn't bitrot. Hope nothing breaks too badly (run away if it does). Missing functionality: save/load/copy/paste/export/print.. but its damn good on canvas  
16769 3935d 10h craig /trunk/Scribus/CMakeLists.txt Only use POPPLER_INCLUDE_DIR if we have poppler  
16729 3944d 20h fschmid /trunk/Scribus/CMakeLists.txt Initial commit of a popper based pdf importer. This importer needs at least poppler-0.17.1 to work.
+ fixes for pattern export in pdf and pdf
 
16348 4111d 19h craig /trunk/Scribus/CMakeLists.txt Fix oops in versioning changes  

Show All