Subversion Repositories Scribus

Rev

Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
24709 115d 08h jghali /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt #16640: ScZipHandler does not get linked into the executable  
24704 148d 09h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt #16617: CMake updates  
24494 336d 19h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Remove QT5_WRAP function usage and rely on autogeneration of ui and moc related files, another step towards Qt6  
24275 423d 10h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Add in ability to use precompiled headers on non-Windows platforms with
-DWANT_PCH=ON CMake parameter
 
21543 1879d 08h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Switch to lower case CMake commands  
18448 3060d 09h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Tidy up indenting in CMake files  
18446 3060d 10h craig /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Remove USE_QT5 and all the Qt4 only code. Remove some QT version >4 code. Remove some cmake 2.6 cmake code, Set minimum cmake to 2.8.9 and qt min version to 5.0.0  
18194 3237d 08h fschmid /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Port to Qt5:
To enable building against Qt5 use the new commandline options:
-DUSE_QT5=1
-DQT_PREFIX="path _to_your_Qt5_installation"
when calling cmake
Only thing that does't work is the upgradechecker class as it depends on deprecated Qt4 classes, and needs a complete rewrite.
Default for building is still Qt4, so a normal cmake call without the options above still results in a build against
Qt4.
 
17199 3658d 19h fschmid /trunk/Scribus/scribus/plugins/import/idml/CMakeLists.txt Replaced the old non working IDML importer by a new working one.