Subversion Repositories Scribus

Rev

Go to most recent revision | Show changed files | Details | Compare with Previous | Blame | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
22440 1606d 00h jghali /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp #15208: Fix build with Qt 5.11 (missing headers)  
21222 2303d 00h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Fixed Bug #13973: mesh distortion for outlined text  
20694 2399d 03h craig /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Some function renames in ScribusDoc  
20185 2608d 23h craig /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Move util_icon to new IconManager for preparation for new xml base iconset definition  
18446 3265d 00h craig /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Remove USE_QT5 and all the Qt4 only code. Remove some QT version >4 code. Remove some cmake 2.6 cmake code, Set minimum cmake to 2.8.9 and qt min version to 5.0.0  
18194 3441d 23h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Port to Qt5:
To enable building against Qt5 use the new commandline options:
-DUSE_QT5=1
-DQT_PREFIX="path _to_your_Qt5_installation"
when calling cmake
Only thing that does't work is the upgradechecker class as it depends on deprecated Qt4 classes, and needs a complete rewrite.
Default for building is still Qt4, so a normal cmake call without the options above still results in a build against
Qt4.
 
18122 3477d 19h mrdocs /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Update the FSF Address to avoid build warnings from OBS  
18007 3512d 23h craig /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Complete TODO: Remove pageitem Frame member, replace with readonly version and remove all setter code  
16311 4215d 02h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Initial committ of the new "Spiral" tool.  
16118 4253d 21h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Fixes for group sizes after applying a "Lens" or "Mesh Distortion" effect.  
16116 4253d 23h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Made the Mesh Distortion Plugin working again.  
15344 4409d 12h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Updated lib2geom to latest version.  
14398 4627d 14h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp First part of "Vector Brushes" + several other small fixes.  
14276 4658d 13h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Fixed Bug-Nr. 4637: "Option to mirror patterns"  
14260 4664d 12h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Allow shearing for fill and stroke patterns.  
14223 4674d 14h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Updated the mesdistortion and lenseffect tools to us the new stroke modes.  
13951 4726d 09h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Removed the use of deprecated QMatrix class.  
12731 5044d 00h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Fixed Bug #7525: "Control points in the Mesh Distortion dialog don't coincide with the grid of the dialog"  
12702 5048d 23h fschmid /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp Fixed the Bug: "Mesh distortion doesn't work for rotated objects, as the mesh doesn't cover the object anymore after the rotation"  
12665 5055d 02h jghali /trunk/Scribus/scribus/plugins/tools/2geomtools/meshdistortion/meshdistortiondialog.cpp #7480 : apply mdoubez's patch for lib2geom compilation under msvc  

Show All